Unable to Download Mac PercX installer pkg



  • Good day Gentlemen,
    I have been unsuccessfully attempting to download the Mac PercX 1.1 pkg ever since I made the purchase. I am met with

    ams3.digitaloceanspaces.com took too long to respond.

    Innovative software but shocking product delivery and website backend from my experience so far. If a member of staff could resolve my issue and provide a download link that works that would be much appreciated. I have tried multiple browsers to no avail currently.

    Regards,

    Ascendant



  • Just checked the download, it works fine here, but we'll look into it.



  • @Christoph-Hart said in Unable to Download Mac PercX installer pkg:

    Just checked the download, it works fine here, but we'll look into it.

    Hello Christoph, rather than simply saying it works fine for yourselves and youll look into it can someone please provide a paying customer with a reasonable way to obtain there purchase. i.e a personal download link or some such in the meantime. I have now made numerous attempts to get some support and its not forthcoming. Just to clarify I have attempted to download the MacOS PercX 1.1 pkg from numerous (three) different networks on numerous devices and through four browsers. All say the same so this simply is not a random user/ home network issue. Can someone please provide me with a way to resolve my current predicament. Why does it appear to be so difficult to get any support from you as developers, you've seen the issues but no one has responded to myself directly. The forum is littered with similar issues such as the one I am voicing and currently I feel as though I won't be heard unless I am vocal publicly so you will be inclined to respond.

    Regards,
    Ascendant



  • I've sent you a link to a custom upload somewhere else, but if you can't reach the PercX server from your location for any reasons, it might be possible that you will run into the same issue again during the sample download process.



  • Good afternoon Christoph. Thank you very much for getting back to me. As you have stated the dropbox link worked immediately and without issue I am now met with 404 error and no download on any of the sample content within PercX. What can be done to allow me to download 91 kits of sample content?
    I very much appreciate you guys corresponding and looking into a work around for the dilemma and I will let that be known on my any past and future posts here on the forum. Hopefully we can get this sorted and I can get on enjoying PercX!



  • In which country do you live? AFAIK our web server uses a distributed server network to provide the files and there might be an issue with the one at your location, because in Europe (Germany) both the installer download and the sample download work perfectly.



  • @Christoph-Hart I am based in England UK. It would appear there is an issue across England as I remotely logged in two colleagues networks both of which are hundred of miles away from myself and the same problem was experienced attempting to download the installer. If a temporary download location for the sample content can be arranged that would be appreciated. Thank you Christoph



  • I am afraid that is not possible - the server also encodes your license information into the metadata of each kit so it's not just a plain old link like the installer. I have notified our web developer about this issue and he will look into that.



  • Admin here..

    All servers seem to be operational, and there should be no problem in obtaining the installer and the samples.
    https://status.digitalocean.com/

    @Ascendant
    First of all apologies for the inconvenience!
    Did you make sure that you dont have a firewall that is blocking PercX from accessing the internet (little snitch..).
    The 404 implies that PercX somehow can't reach the server infrastructure.

    We'll figure this out!

    Best,
    Dominik



  • @do

    Hello Dominic, yes a, I have no firewalls, nothing stopping incoming traffic. I have taken my Mac to several different networks to check and I am still met with the same message. Even when the 404 error in red box doesnt appear (does sometimes not others when opening the PercX AU) it says then queueing downloads of 91 kit, first one just says 0/kbs and never begins to download. Left several hours to no avail. I have more audio units than I care to list and hundreds of remote installed sample libraries from NI, Impact Soundworks, iZotopes, Spitfire etc and have never encountered any issues so certainly nothing from a system or network point of view my end. Please let me know what your enquiries into the server and UK based people brings up and I hope we can find a swift resolution to the problem.


Log in to reply