PERC X Unresponsive - Cannot view, download or use any kits



  • Hey, guys.

    I just tried scouring these forums for some answers and couldn't find anything related to my issue. I purchased PercX on 11/24/2019 during the intro sale and have finally gotten around to really digging in (I briefly tried it out after purchasing on my trash can Mac Pro, but never really went too in depth. I've since upgraded to a new Mac Pro.).

    The problem I'm having is this: First, when I initially opened the instrument the other day, I was greeted with a message that said :

    "Error at loading Expansion Cracky Djuns: Invalid Machine ID. In order to solve this, go to the store and run the Repair Kit function (from the context menu of the account tab icon)."

    Screen Shot 2020-08-22 at 1.51.10 AM.png

    After following those instructions, nothing happens. Even when I click on the store within the app in order to click "refresh" next to my account in order to see all of my available kits to download, nothing is responsive. The refresh button does nothing and even clicking "logout" on the account dropdown menu does nothing. Underneath "Account", it says "Fetching user data", but it doesn't seem to ever fetch any data whatsoever. It kinda just sits there.

    Screen Shot 2020-08-22 at 2.16.50 AM.png

    I've tried completely uninstalling it and redownloading it from scratch multiple times and, still, no luck. I'm not sure if this is a server issue or possibly a Catalina issue or what. Either way, the instrument is completely useless and I'm stuck. Any suggestions? Really hoping to use this instrument on a current project.

    Cheers,
    Ben



  • Dear @BenHicksMusic

    First of all, sorry for this inconvenience! The first version of PercX (1.0) had a bug that sometimes corrupted the authentiction file after a system (OS) update. This may lead to PercX not being able to connect to the STORE and therefore no way repair the problem with the "Repair function".

    The quickest way to fix this:

    Go to the Appdata Folder in your OS:
    (Win: C:\Users\USERNAME\AppData\Roaming\Auddict\PercX\..)
    (macOS: ~/Library/Application Support/Auddict/PercX/..)
    and delete the .license file that you'll find in there.

    After closing&reopening PercX you should be able to authenticate PercX again with your credentials (email&password), and access the STORE right away.

    If the "expansion error" still persists, you can click on the little Account icon on the top-left of the STORE and try: "Repair Kits" and "Validate Sample Data" to fix issues with corrupted Expansions/Kits.

    I hope this helps! Please let me know if you run into any issues, and i'll help you out.

    Best regards,
    Dominik



  • That seems to have done the trick. Thanks, Dominik!


Log in to reply