PercX crashes when dragging midi notes into Logic pro X

  • PercX crashes when dragging midi notes into Logic pro X. I am on macOS Catalina. Please advise.

    Here is the error message details:

    Exception Name: NSInvalidArgumentException
    Description: *** -[__NSArrayM insertObject:atIndex:]: object cannot be nil
    User Info: (null)

    0 CoreFoundation 0x00007fff3995db57 __exceptionPreprocess + 250
    1 libobjc.A.dylib 0x00007fff727a65bf objc_exception_throw + 48
    2 CoreFoundation 0x00007fff39a0c59e -[__NSCFString characterAtIndex:].cold.1 + 0
    3 CoreFoundation 0x00007fff39a0a573 -[__NSArrayM insertObject:atIndex:].cold.2 + 0
    4 CoreFoundation 0x00007fff3987dfb5 -[__NSArrayM insertObject:atIndex:] + 1155
    5 AppKit 0x00007fff3711d594 -[NSCoreDragManager beginDraggingSessionWithItems:fromWindow:withClipRect:event:source:] + 745
    6 AppKit 0x00007fff374236ad -[NSView(NSDrag) beginDraggingSessionWithItems:event:source:] + 259
    7 PercX 0x000000011a6eb823 _ZN4juce20repostCurrentNSEventEv + 1053731
    8 PercX 0x00000001199230cf DemoProjectAUFactory + 1581199
    9 PercX 0x000000011a6c89f1 _ZN4juce20repostCurrentNSEventEv + 910833
    10 PercX 0x000000011a6d15f3 _ZN4juce20repostCurrentNSEventEv + 946675
    11 PercX 0x000000011a6d131e _ZN4juce20repostCurrentNSEventEv + 945950
    12 PercX 0x000000011a6cbcb6 _ZN4juce20repostCurrentNSEventEv + 923830
    13 Foundation 0x00007fff3bfb60dd __NSThreadPerformPerform + 204
    14 CoreFoundation 0x00007fff398e1d52 CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION + 17
    15 CoreFoundation 0x00007fff398e1cf1 __CFRunLoopDoSource0 + 103
    16 CoreFoundation 0x00007fff398e1b0b __CFRunLoopDoSources0 + 209
    17 CoreFoundation 0x00007fff398e083a __CFRunLoopRun + 927
    18 CoreFoundation 0x00007fff398dfe3e CFRunLoopRunSpecific + 462
    19 HIToolbox 0x00007fff3850cabd RunCurrentEventLoopInMode + 292
    20 HIToolbox 0x00007fff3850c6f4 ReceiveNextEventCommon + 359
    21 HIToolbox 0x00007fff3850c579 _BlockUntilNextEventMatchingListInModeWithFilter + 64
    22 AppKit 0x00007fff36b52039 _DPSNextEvent + 883
    23 AppKit 0x00007fff36b50880 -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 1352
    24 Logic Pro X 0x000000010881ce00 Logic Pro X + 27622912
    25 AppKit 0x00007fff36b4258e -[NSApplication run] + 658
    26 AppKit 0x00007fff36b14396 NSApplicationMain + 777
    27 Logic Pro X 0x00000001079bae5d Logic Pro X + 12541533
    28 libdyld.dylib 0x00007fff7394ecc9 start + 1

  • +1 for this post--- @waeld I am having the same symptoms today in ProTools as well. I am unable to upload my crash details since it is in Console and I cannot get it to paste into Pages for some reason. Auddict folks: any thoughts? I'm out of business with Perc X until I can get past this one. Ty!!


  • I'll take a look, but I tested the dragging feature (at least in Logic). @lctofu are you also using Catalina?

  • Hi Chris- Thanks for the reply!

    No- I am a holdout, using High Sierra still, 10.13.6. The OS updates have been brutal and I am still waiting. If helpful I can email you the Console crash log. Just let me know where to send that.

  • @Christoph-Hart So what should I do? I just purchased the plugin and the dragging never worked, it crashes since day one. Should I uninstall and reinstall? If it won't work I'll have to ask for a refund. Thanks.

  • @Christoph-Hart ditto here. Dead in the water.

  • I‘m currently working on an update and I‘ll try to include a fix. Does the crash appear every time you drag something and does it crash if you start dragging or if you drop it in your DAW?

  • Hello @Christoph-Hart - Here is a video of how the crash happens. It's basically as soon as I start dragging out of PercX. @waeld

    Thanks for your assistance- fingers crossed.


  • @Christoph-Hart Logic pro X internal error message appears with two options to choose from (Crash or Continue), as soon as I click on the PLAY symbol or TARGET symbol of PERC X (in Edit A window, Drag), before even being able to drag and drop the midi. Thank you.

  • @Christoph-Hart Just checking in-- any more info/luck in figuring this out? Thanks!


  • Unfortunately no. I can drag the files without any problems.

    Can you check whether the standalone app crashes too? You can drag the MIDI on the desktop and it will create a file called Temp.mid. Just checked with Catalina and it works (I haven't installed Logic / Protools yet on Catalina, but in Mojave it works).

    I could build a version of PercX where you can skip things during the MIDI file creation so that we narrow down the location where the crash happens.

  • @Christoph-Hart I tried to drag standalone MIDI to desktop, but it doesn't seem to be working. Here's a video, maybe I am doing something wrong?

    Also, here is a link to the .crash log from today's crash when I tried it again in ProTools:

    Lastly, I am on ProTools version 2020.11.0 (High Sierra 10.13.6)-- what version of PT are you using when you test and it works AOK on Mojave?



  • Hi Larry,

    thanks for the video. There's a small glitch in the UI so you need to select at least one track after opening the dragging tab in order to create a file (just click on the ALL Button on the left just before starting the drag).

    I haven't tried dragging nothing around, so I tomorrow I try if this causes the crash 🙂

  • Good lord it worked! I selected an instrument on the left before dragging as you said and badaboom! The small glitch is provoking the crash but now we can avoid it and the dragging is working. Thank you!

  • Ah, good to know, but I'll try to fix it anyway - a hard crash is not the most subtle hint that a function is not working properly 🙂

  • @Christoph-Hart @waeld Wooohoooo! Worked for me as well-- WHEW!!! Yay! Agreed-- will be better that it doesn't crash should we forget to do that, but this puts me BACK IN ACTION! 🙂

Log in to reply